Automatic mode: problem with nature photos

suggest a way to improve Neat Image
Post Reply
lazzaraalessandro
Posts: 2
Joined: Mon Sep 18, 2017 10:18 am

Automatic mode: problem with nature photos

Post by lazzaraalessandro » Mon Sep 18, 2017 12:14 pm

Hi. Thanks for this fantastic noise removal tool.
I use a lot autoprofile using command line exe.
in 90% cases it works very good..
the only problem is in photos with green nature (grass, trees, etc): seems that in this case for example grass is considered as noise and generate a blurred photo.
If you fix this problem in automatic mode, in my opinion neat image will be perfect.

Thanks

NITeam
Posts: 3114
Joined: Sat Feb 01, 2003 4:43 pm
Contact:

Post by NITeam » Sat Sep 23, 2017 7:11 am

It may be possible to avoid that problem by using a good set of re-usable profiles that would be selected by Auto Match. Please see the user guide for more details.

Thank you,
Vlad

fenomeno83
Posts: 27
Joined: Fri Jan 19, 2007 5:48 pm

Re: Automatic mode: problem with nature photos

Post by fenomeno83 » Sat Mar 10, 2018 11:49 am

Ok thanks.
Any possibility to have in future this improvement in autoprofile?
Thanks

NITeam
Posts: 3114
Joined: Sat Feb 01, 2003 4:43 pm
Contact:

Re: Automatic mode: problem with nature photos

Post by NITeam » Sat Mar 10, 2018 1:30 pm

If you want to combine the benefits of Auto Profile and Auto Match, please see (in the user guide) the description of the function called Smart Profile.

Thank you,
Vlad

fenomeno83
Posts: 27
Joined: Fri Jan 19, 2007 5:48 pm

Re: Automatic mode: problem with nature photos

Post by fenomeno83 » Sat Mar 10, 2018 2:16 pm

thanks..
i've used this image as test:
https://upload.wikimedia.org/wikipedia/ ... e-View.jpg

with command line tool i've tried with -ap and then with -sp, but it generates the same file with the same size (the result is blurred in this case).
I've tried with several photos, but the 2 profiles generates always the same file.

What am I wrong?
Thanks

NITeam
Posts: 3114
Joined: Sat Feb 01, 2003 4:43 pm
Contact:

Re: Automatic mode: problem with nature photos

Post by NITeam » Sat Mar 10, 2018 2:25 pm

Please kindly read about Smart Profile function to learn how it works by using a set of pre-built profiles (that you have to build in advance).
You do need to prepare such a set of profiles first and only after that you can make Smart Profile work differently and potentially better than Auto Profile.

Thank you,
Vlad

fenomeno83
Posts: 27
Joined: Fri Jan 19, 2007 5:48 pm

Re: Automatic mode: problem with nature photos

Post by fenomeno83 » Sun Mar 11, 2018 5:16 pm

thanks...I'm trying, but I've difficult to build an appropriate profile for nature photos.

For example, starting from this https://upload.wikimedia.org/wikipedia/ ... e-View.jpg
,i select some area, than click on autoprofile, but when go to output image always generates blur--> so i don't want save this profile to use in Smart profile combined with autoProfile, because it is not a good profile

I'd like build a profile for "nature photos" that isn't applied any denoise (or applied a little where is needed)--> so, when use smart profile, it understand if apply AutoProfile or builded Profile(more appropriate for nature photos).
This because i use an automatic batch that processes a set of images; in 90% of cases it does a fantastic work, but in some cases(expecially in photos with nature) it fails and blur the details like grass(in this case i prefer that doesn't apply denoise)

What do you suggest to build a profile that don't blur photo when it is a nature photo

NITeam
Posts: 3114
Joined: Sat Feb 01, 2003 4:43 pm
Contact:

Re: Automatic mode: problem with nature photos

Post by NITeam » Sun Mar 11, 2018 6:27 pm

Please kindly notice that if you want to build a reusable set of profiles, then you do that for different shooting modes of your camera (different ISO levels, different compression settings, etc.). To build such a reusable set of profiles you need to use a special test image (you cannot use an image that is not suitable for profiling because it contains no featureless areas) and follow the steps described in the Device Noise Profiles section of the user guide. Please try to follow the steps described in that section, it will help you build a set of good profiles for your camera. Those profiles will then help you process images even if they have no suitable areas for profiling. You will instruct Neat Image to use Auto Match and it will use one of the pre-build accurate noise profiles instead of using the inaccurate profile built using such a working image unsuitable for profiling.

Thank you,
Vlad

fenomeno83
Posts: 27
Joined: Fri Jan 19, 2007 5:48 pm

Re: Automatic mode: problem with nature photos

Post by fenomeno83 » Sun Mar 11, 2018 11:19 pm

Ok thanks. I will try with custom profile following guide.
I would have liked to have something of "generic" and "automatic" that understand area with grasses for example and don't consider it as noise. For this reason I asked in first post to make an improvement in neat image to works better with "nature photos", because these types of images are most common where neat image fails and blur them (in auto profile mode). I don't know if in future is possible.
Thanks

NITeam
Posts: 3114
Joined: Sat Feb 01, 2003 4:43 pm
Contact:

Re: Automatic mode: problem with nature photos

Post by NITeam » Sun Mar 11, 2018 11:41 pm

This is a difficult thing to do because it is not trivial to determine if there is only noise or some details as well. That is why Neat Image asks you to visually check the area used for profiling and not use an area with details. In situations when you cannot do such a visual inspection, the solution offered by Neat Image is to use a pre-built set of good noise profiles (that you build for your camera using a special test image) and then to pick one profile matching the current image based on the EXIF metadata. That is what Auto Match does currently.

We will of course continue to improve the Auto Profile function to make it work better.

Thank you.

fenomeno83
Posts: 27
Joined: Fri Jan 19, 2007 5:48 pm

Re: Automatic mode: problem with nature photos

Post by fenomeno83 » Thu Mar 15, 2018 10:35 pm

Ok thanks.
Any news on next update date?

NITeam
Posts: 3114
Joined: Sat Feb 01, 2003 4:43 pm
Contact:

Re: Automatic mode: problem with nature photos

Post by NITeam » Thu Mar 15, 2018 11:02 pm

There is no fixed date yet.

Post Reply