Adobe Encoder take FOREVER if I use Neat Video

resolve technical issues related to use of Neat Video
Post Reply
Rancor12
Posts: 4
Joined: Mon Jul 22, 2019 11:42 pm

Adobe Encoder take FOREVER if I use Neat Video

Post by Rancor12 » Tue Oct 08, 2019 3:10 pm

So I'm trying to use Adobe Encoder for a 8 minute video, 1080p 24fps, in H264,

Using render maximum bit depth and maximum bit quality. Also using VB 2 pass with 20/30 as my target and max.

I have a new 9th gen i7 turboing up to 4.2Ghz and a 1660 Ti with 6GB. The only possible bottleneck I can think of is that I'm only running 8GB of 2333 DDR4 RAM.

And when I say takes forever, I mean I have my primary video track, 2 audio tracks (one vocal and one bg music) and my adjustment layer, which only contains 2 effects, lumetri color for color correction, exposure, and a simple LUT, and then Neat video. WITHOUT Neat Video, the entire render and export via encoder takes 12 minutes. When I add Neat Video it takes 6+ hours, and even after letting it run overnight, I wake up to 58%, and it almost seems to have stalled out.

Is this a RAM issue, or am I doing something wrong?

Does Neat video need to be directly on the video track as opposed to an adjustment layer? Does it matter if it is above or below lumetri color?

Thanks for any help.

NVTeam
Posts: 2403
Joined: Thu Sep 01, 2005 4:12 pm
Contact:

Re: Adobe Encoder take FOREVER if I use Neat Video

Post by NVTeam » Tue Oct 08, 2019 3:47 pm

1. Lumetri is a performance killer when Lumetri is applied before/above a temporal effect like Neat Video. Move Neat Video above Lumetri to avoid that. Better put Neat Video as the first effect.

2. 8GB of RAM may be somewhat low for modern video processing. Check the memory utilization during rendering using Task Manager. If you see it hitting the limits of physical memory then try to vacate some memory by closing other applications. If that doesn't help, try to export using Premiere itself instead of using Encoder.

3. Make sure you run Optimize Settings tool in Neat Video Preferences to choose the best settings.

4. See more recommendations in this article.

Thank you,
Vlad

Rancor12
Posts: 4
Joined: Mon Jul 22, 2019 11:42 pm

Re: Adobe Encoder take FOREVER if I use Neat Video

Post by Rancor12 » Tue Oct 08, 2019 3:55 pm

NVTeam wrote:
Tue Oct 08, 2019 3:47 pm
1. Lumetri is a performance killer when Lumetri is applied before/above a temporal effect like Neat Video. Move Neat Video above Lumetri to avoid that. Better put Neat Video as the first effect.

2. 8GB of RAM may be somewhat low for modern video processing. Check the memory utilization during rendering using Task Manager. If you see it hitting the limits of physical memory then try to vacate some memory by closing other applications. If that doesn't help, try to export using Premiere itself instead of using Encoder.

3. Make sure you run Optimize Settings tool in Neat Video Preferences to choose the best settings.

4. See more recommendations in this article.

Thank you,
Vlad
Thanks a bunch. I just ran the optimizer and learned something interesting. For some reason, on this new laptop (about 3 months in and still finding interesting "quirks") applications aren't utilizing my graphics card by default, and are instead using the on board intel graphics, even though I have the system wide default set to use my 1660ti. I first found this out when my Minecraft FPS was like 16. Apparently I have to create a desktop shortcut for the app in question so that I can right click and select "Run with Nvidia Graphics". Pretty damn ridiculous.

Turns out Premier (And probably Encoder) are having this same issue, which I discovered when I went to optimize the Neat Video settings and it said "No GPU Found". So now that I have "Run with Nvidia" and optimized the settings to use both CPU cores and CUDA, I am getting 'faster' speeds, but the time is still very long. 3+ hours for an 8 minute video.

I'll try rearranging the effects in my adjustment layer so that Neat is above/before Lumitri.

I also found a pack of 2333 with a cache speed of 15 (nice a fast), 32GB for $130. Probably gonna order that soon cause why not.

Rancor12
Posts: 4
Joined: Mon Jul 22, 2019 11:42 pm

Re: Adobe Encoder take FOREVER if I use Neat Video

Post by Rancor12 » Tue Oct 08, 2019 4:11 pm

Okay so I figured out how to REALLY set my GPU as my global default (Nvidia needed to be in charge vs Windows at a global level).

I also placed Neat Video before lumitri.

Now I'm down to a render time of 1 hour for my 8 min video, which I can totally live with. The process does seem to be maxing out my 8gb of ram, looking at the tracker it's riding right around 7.8 out of 8, so that's basically throttled. CPU is cruising around 3.2 Ghz and GPU is only at 15% usage.

So, I'll be ordering some more RAM soon.

HOWEVER, is running Neat before Lumitri going to be less effective due to the additional noise sometimes added by increasing shadows and such, which will be added after the baseline noise is cleaned? Or is the difference negligible.

NVTeam
Posts: 2403
Joined: Thu Sep 01, 2005 4:12 pm
Contact:

Re: Adobe Encoder take FOREVER if I use Neat Video

Post by NVTeam » Tue Oct 08, 2019 4:46 pm

The problem with Lumetri is that it has a bug that causes Premiere to re-render many frames several times. Hence a slowdown and higher memory usage. Try to render a short test clip with Lumetri (placed after Neat Video) and without Lumetri at all. It is possible that there is an appreciable difference as well.

Vlad

Post Reply