CPU/GPU settings not honored during export

resolve technical issues related to use of Neat Video
Post Reply
Trixter
Posts: 10
Joined: Wed Jun 06, 2012 2:34 pm

CPU/GPU settings not honored during export

Post by Trixter » Tue Jan 09, 2018 2:50 am

I'm a happy registered user of NeatVideo for over 5 years. I recently had to reload my editing computer to Windows 10 and Premiere CC 2018, and I reinstalled the NeatVideo 4.7 SR plugin. I get the best performance on my system setting GPU only for filter operation, but I just noticed during export via media encoder, my GPU-only setting is not being honored. I see extremely high CPU utilization on export whenever the filter is enabled, even on uncompressed export targets. When I temporarily disable the NeatVideo filter, exports occur at full speed, so I've definitely narrowed it down to NeatVideo.

I have set my sequence to both regular and "maximum bitdepth", and I set "GPU only" in tools->preferences->performance for both, and I can definitely confirm that during editing or playback from the timeline, only the GPU is in use, but on export via Media Encoder, NeatVideo reverts back to using the CPU. (I'm verifying this by watching both a CPU and GPU usage meter during my tests.) I tried exporting not as maximum bitdepth, so that it could match the sequence settings, but I'm still seeing massive CPU usage on export.

I'm guessing that during export, some bit depth that is not available during tools->preferences->performance is being used, so it uses whatever the default performance settings are. How can I configure NeatVideo so that it uses GPU only for rendering and export scenarios?

NVTeam
Posts: 2309
Joined: Thu Sep 01, 2005 4:12 pm
Contact:

Post by NVTeam » Tue Jan 09, 2018 3:59 pm

Setting "maximum bitdepth" usually affects the way Premiere itself works and also whether it uses GPU or CPU in some cases, as far as I know.

Anyway, please try the following:

0. Please set the plug-in to use the GPU only. (It will still use some CPU too, that is not abnormal. However most of the work should be done on the GPU.)

1. Please restart Windows, re-open the plug-in and verify that it still shows GPU-only in its Preferences.

2. Then please try to export a test project (I assume you use a fresh new test project created with the SR version, not an older project based on the standard version) using Premiere itself, without ME. Check if the GPU load is the same as when you just make a preview render inside Premiere.

3. If everything is right so far, please proceed to export the same project via ME. Check if the GPU is used.

4. If it is not used, then please install the standard plug-in and repeat the steps 2-3 using another test project with the standard plug-in instead of SR.


Please let me know your observations then.

Thank you,
Vlad
Image Image Neat Video team
noise reduction for video and photos

Trixter
Posts: 10
Joined: Wed Jun 06, 2012 2:34 pm

Post by Trixter » Wed Jan 10, 2018 1:10 am

Thanks very much for the troubleshooting advice. Upon following the steps, I noticed something very odd -- Premiere used full CPU for any effect that needed rendering, not just NeatVideo. To confirm, I rendered a 240-frame work area with only NeatVideo in three configurations and had the following results:

gpu only: 50
cpu only, 12 cores: 123
cpu + gpu, (5 cores found by Optimize): 50 seconds

In all three instances, all 12 cores were pegged at 100%, but it was clear the GPU-only setting was working due to the reduced render time. So, NeatVideo is not to blame, and somehow Premiere is. My source asset (1080p24) is stored in a lossless codec that decodes 50+ fps using only one core, so I'm very confused why Premiere Pro CC 2018 burns all 12 cores at 100% when rendering even a simple effect (I tried "magnify" as a test since it turned the render bar red), but the proof is there -- NeatVideo is operating as designed.

Thanks very much for the timely response and a continued great product. You can close this issue.

Post Reply