Field Order changed during processing

general questions about Neat Video
Post Reply
Andrisim
Posts: 5
Joined: Sun May 08, 2011 10:14 am

Field Order changed during processing

Post by Andrisim » Sun Jan 29, 2012 8:21 am

With respect to Field Order - NV/VirtualDub

I have found that if I start with a SD avi clip having Field Order = Upper, the processed clip has Field Order = Lower.

Whereas, when I repeated the test with a SD avi clip having Field Order = Lower, after processing it was still at Lower.

Am I to conclude that NV always wants to "see"" SD avi clips having Field Order = Lower?

FYI : Codec is Canopus HQ @ 720x576 50i or 720x480 59.94i, not DV.

NVTeam
Posts: 2274
Joined: Thu Sep 01, 2005 4:12 pm
Contact:

Re: Field Order changed during processing

Post by NVTeam » Sun Jan 29, 2012 11:57 pm

Andrisim wrote:Am I to conclude that NV always wants to "see"" SD avi clips having Field Order = Lower?
No, NV does not require any specific order and does not change the order when processing the video stream. Any change of the order that you observe is applied in another part of the decoding/rendering/encoding dataflow, not in/by NV.

Vlad
Image Image Neat Video team
noise reduction for video and photos

Andrisim
Posts: 5
Joined: Sun May 08, 2011 10:14 am

Post by Andrisim » Mon Jan 30, 2012 6:57 am

Just to make sure :

My editor is Canopus Edius 6 and the avi is exported as Canopus HQ codec 720x480 50i Upper Field. NV processes it in VirtualDub.

When I raised this matter on the Canopus Forum, the reply from a senior contributor was as follows:

Canopus HQ does not provide field order info to other programs, so other programs need to guess and Neat Video guesses wrong

so when you put the Neat video file back in EDIUS, it will flicker, so go to clip properties and change it to upper and it will be fine


Based on what you say, if NV is not doing it could it be VirtualDub?

NVTeam
Posts: 2274
Joined: Thu Sep 01, 2005 4:12 pm
Contact:

Post by NVTeam » Mon Jan 30, 2012 10:30 am

Could be. Try to process the original file using VirtualDub without NV (perhaps with some other filter from VirtualDub itself), and ensure the output is correctly encoded.

Vlad
Image Image Neat Video team
noise reduction for video and photos

Andrisim
Posts: 5
Joined: Sun May 08, 2011 10:14 am

Post by Andrisim » Mon Jan 30, 2012 12:17 pm

I just ran a test using VirtualDub VHS Filter.
The original Upper Field avi after processing shows as Lower Field when put back on the Timeline.

NVTeam
Posts: 2274
Joined: Thu Sep 01, 2005 4:12 pm
Contact:

Post by NVTeam » Mon Jan 30, 2012 1:37 pm

Must be VD then, or the codec it uses to encode the output. Try to adjust the codec settings. Also check the VD documentation or ask VD developer for additional details.

Vlad
Image Image Neat Video team
noise reduction for video and photos

Post Reply