VirtualDub with NeatVideo plugin running out of memory?

resolve technical issues related to use of Neat Video
Post Reply
Posts: 26
Joined: Mon Mar 05, 2012 2:19 pm

VirtualDub with NeatVideo plugin running out of memory?

Post by AndCycle » Wed Aug 08, 2012 3:17 am

I am just using VirtualDub with NeatVideo 3.2 to process my raw video,
it kicks out a message said,



Line: 253
Func: Malloc
Error: Neat Video (32 bit) cannot get free memory block from the operating system (or plug-in) host).
(1036800-byte memory block is requested from: 90f4ac53)

Please make more memory available for application and retry.


I can see the virtualDub using 1.5G memory in task manager,
I am not sure who is leaking inside, NeatVideo is the only filter I used,

after I hit ok the progress keeps running,
will this effect my final render result? or everything will be fine?

Posts: 196
Joined: Mon Aug 11, 2008 7:33 am

Post by jpsdr » Wed Aug 08, 2012 7:36 am

What version of VDub ?
I've personnaly used VDub+NeatVideo a lot of time to process full HD video, on a PC under WinXP SP3 with 2Go of RAM without any issue.
It's the first time i see someone with memory issue with VDub.
What temporal radius ? (In my case i use 2). If i remember properly, during HD process, VDub used something around 700MB or less, in my case.

What codec do you use for you video ? (Input/output).

Posts: 26
Joined: Mon Mar 05, 2012 2:19 pm

Post by AndCycle » Wed Aug 08, 2012 6:51 pm

oops, sorry for missing the detail, I am trying different combination to locate the problem,
looks like this doesn't related to NeatVideo,

here is the original setup

source file is mov, Apple ProRes HQ, recorded by Atomos Samurai,
4hrs footage 1080 59.94i,
VirtualDub 1.9.11 (32bits) QuickTime.vdf by tateu,
NeatVideo 3.2, cpu only, interlace mode, radius=5,
video compression is x264vfw_37_2200,
audio direct copy,
target for single pass qp=0 keep color space lossless.avi

I am currently test this,

VirtualDub 1.10.2-AMD64, FFInputDriver 0.7,
x264vfw64 same version, same filter and setup,

have to wait it for a day to see the memory usage,

even if it's still leaking, I think it can survive this time,
because last time 32bits setup crashed with 1.6GB at 20% progress,
64bits with 8GB is enough for it to get over with this issue, for now.

Posts: 196
Joined: Mon Aug 11, 2008 7:33 am

Post by jpsdr » Thu Aug 09, 2012 7:28 am

I think the issue is that you may be doing too much things in the same operation : Filter (high CPU & memory usage) + x264 encode (idem).
Personnaly, i separate steps, for a lot of reasons. One of them, is that if you need to redo the x264 encode, you don't need to the filtering.
My advice (what i'm personnaly doing when working on video) : Save the filtered file, or more precisely, the final result just before encoding (so with all the video processing you have to do) in a lossless YV12 format.
The only codec i know (but maybe there is others) which produce YV12 and works both on x86 and x64 are "Lagarith" or "UT Video". Lagarith give a little better compression (around 10%), but is 3 times slower than UT Video.
This will create a file of around 300GB i think.
Also, radius 5 is high, and will use more memory than 2 that i personnaly use... Better reason i think to separate steps...

Posts: 26
Joined: Mon Mar 05, 2012 2:19 pm

Post by AndCycle » Fri Aug 10, 2012 8:34 am

thanks for your advice :)

Posts: 1
Joined: Mon Oct 01, 2012 9:33 pm

Post by JClement » Tue Oct 02, 2012 12:13 am

This leak is about 22kbytes/frame for a conventional VHS video. I did a test with 5 hoggish filters in a row. They increased the memory initially, but after that the memory stayed about the same. By contrast Neat Video kept on increasing the memory.

OK, it is possible to do the video in segments, but no filter should cause memory to increase so you run out in a 2hour NTSC video. So far support is stonewalling it.

OK, I can use the 64bit version, but then I lose most of the other useful filters which means I have to save intermediate results. If I wish to prevent degradation I need to use a nonlossy format which gobbles disk space. I do not consider this to be a reasonable solution.

Posts: 2266
Joined: Thu Sep 01, 2005 4:12 pm

Post by NVTeam » Tue Oct 02, 2012 11:14 am

Thanks for sending the profile and settings to support. We have been trying to reproduce the problem using a 2.5GB clip file, NV v3.2 Home plug-in, both 32-bit and 64-bit versions, but so far the problem is not reproducible:
- there is no increase in reported memory usage in the 64-bit version;
- there is no increase in reported memory usage in the 32-bit version.

We did try to run a video analysis pass as well.

Need some help to reproduce the problem. Please advise.

Thank you,
Image Image Neat Video team
noise reduction for video and photos

Post Reply