crippled frames at the Beginning of temporal filtering

resolve technical issues related to use of Neat Video
Post Reply
spreeni
Posts: 5
Joined: Wed Apr 18, 2007 4:08 pm

crippled frames at the Beginning of temporal filtering

Post by spreeni » Thu Apr 19, 2007 9:49 am

Hi,
I'm testing the demo-version of the NV Premiere plugin and was very impressed of the quality of the temporal filtering.
As I use the plugin on small clips in my video-projects I noticed a strange behavior of the temporal filtering: each clip starts with one up to three crippled frames before the filter works as it should. These crippled frames vanish when I disable the temporal filtering (radius 0) and they grow up when using higher radius values. If I decrease treshold values the effect is nearly away, but surely the temporal filtering effect is nearly away, too.
I made a test-clip (PAL DV AVI) with temporal filter radius 3, threshold 200, adaptive filtration 0 to show what I mean.
http://www.mir-studios.de/temporal_filter.avi (2.9 MB)
Is this a normal behavior of the filter?

spreeni

NVTeam
Posts: 2260
Joined: Thu Sep 01, 2005 4:12 pm
Contact:

Post by NVTeam » Thu Apr 19, 2007 3:36 pm

I don't think this is normal. Perhaps those abnormalities in the first frames come from the previous clip that was processed earlier in the time line. Do you have any preceding clips there?

We could try to reproduce this effect if you would send the original clip and your sample project for Premiere that together with NV rendered the same results.

Thank you,
Vlad
Image Image Neat Video team
noise reduction for video and photos

spreeni
Posts: 5
Joined: Wed Apr 18, 2007 4:08 pm

Post by spreeni » Thu Apr 19, 2007 6:52 pm

Thanks for your reply, I made up a Premiere project with only one clip and put this one into the timeline with the nv-filter. No other clip is placed before or after this clip. After rendering I've got the same result: the first and second frame of the movie was distorted. I noticed this effect primarily on clips with heavy movements.

I hope you can reproduce this, I put the Premiere project (Premiere version 1.51) with the testclip into a Zip-File under:

http://www.mir-studios.de/NV-Test.zip (12 MB)

Thanks for your help.

Spreeni

spreeni
Posts: 5
Joined: Wed Apr 18, 2007 4:08 pm

Post by spreeni » Thu Apr 19, 2007 6:56 pm

Oh I forgot to add: I'm still using the demo-version of the filter. While I'm working on a PAL project (720x576), can this be the cause?

Spreeni

NVTeam
Posts: 2260
Joined: Thu Sep 01, 2005 4:12 pm
Contact:

Post by NVTeam » Thu Apr 19, 2007 8:02 pm

Thank you very much for the project. Yes, I could reproduce the effect (it doesn't seem to be dependent on edition of the plug-in)and we will be investigating it in the team now. I will publish an update here as soon as we have any news.

Thank you,
Vlad
Image Image Neat Video team
noise reduction for video and photos

spreeni
Posts: 5
Joined: Wed Apr 18, 2007 4:08 pm

Post by spreeni » Thu Apr 19, 2007 9:45 pm

I'm glad to hear that. Thank you. :)

Post Reply