NeatVideo doesn't work with Premiere Elements 12 Adjustments

resolve technical issues related to use of Neat Video
Post Reply
RankinBassFish
Posts: 1
Joined: Sat May 17, 2014 7:55 am

NeatVideo doesn't work with Premiere Elements 12 Adjustments

Post by RankinBassFish » Sun May 18, 2014 12:17 am

Premiere Elements 12 has a new tab called Adjustments where you can change the gamma, color vibrance, and temperature, etc. NeatVideo works fine with the normal Applied Effects plugins, but once I go into the Adjustments tab, I have to turn off NeatVideo for the color vibrance to work, or vice versa.

So, I have to turn off NeatVideo for the color vibrance (in the Adjustments tab) to work, or I have to turn off color vibrance for NeatVideo to work. This is baffling. Anyone else have this problem, or know how to resolve this? Thanks.

Working on a 2.7 GHz i5 iMac with GeForce GT 640M 512 MB.

NVTeam
Posts: 2261
Joined: Thu Sep 01, 2005 4:12 pm
Contact:

Post by NVTeam » Mon May 19, 2014 3:04 pm

In our tests, that tab also seems to behave a bit strangely. Seems to be a general limitation or bug of Elements.
In our tests however, the following procedure allows to combine both effects:
1. first add Neat Video and set up a noise profile, make sure the noise filter works as you want it to; then close Neat Video window (click Apply);
2. enable color vibrance in Adjustments;

Then Neat Video does still reduce noise and color vibrance is still applied as well.

Hope this helps,
Vlad
Image Image Neat Video team
noise reduction for video and photos

Post Reply