Video clip playing from the start when the plugin is applied

questions about practical use of Neat Video, examples of use
Post Reply
Posts: 1
Joined: Sun May 10, 2015 10:12 am

Video clip playing from the start when the plugin is applied

Post by mynah » Sun May 10, 2015 10:33 am


Sorry if this question has been answered here before. But I need an answer soon as I need to finish my video project.

Im using Premiere Pro CC 2014. I have a timeline with few clips. I want to use the neat video plugin on one of the clips in the timeline. So once I drag and drop the plugin into the clip in the timeline that clip changes. Now suddenly once I apply the plugin the clip is not what I selected and cut. It is showing the clip from its beginning and not from where I selected it. This is really frustrating for me as I dont know what the issue is. Any help much appreciated.



Posts: 2266
Joined: Thu Sep 01, 2005 4:12 pm

Post by NVTeam » Sun May 10, 2015 1:16 pm

That seems to be a result of that old bug in Premiere - it started in CS6 and continued ever since, despite our multiple reports to Adobe:
if you cut a clip and then apply an effect (like Neat Video) that uses the temporal API of Premiere, that Premiere API malfunctions and returns incorrect frames to Neat Video, which results in shifted video after the filter.

It is described in the known issues page.

A couple of possible workarounds are described too, one is more practical than the other.

Hope this helps,
Image Image Neat Video team
noise reduction for video and photos

Post Reply