Issue with VDub version

resolve technical issues related to use of Neat Video
Post Reply
jpsdr
Posts: 201
Joined: Mon Aug 11, 2008 7:33 am

Issue with VDub version

Post by jpsdr » Mon Feb 13, 2017 6:20 pm

Since i've updated to the 4.5, around 50% of the time, VDub hang when i open an avs file or when it want to begin the next job.

NVTeam
Posts: 2303
Joined: Thu Sep 01, 2005 4:12 pm
Contact:

Post by NVTeam » Mon Feb 13, 2017 6:41 pm

Is that 100% reproducible with one specific AVS file
or even if the AVS file is the same, then it hangs with 50% chance?

Does that happen with an AVS file newly created after installation of 4.5?

Thank you,
Vlad
Image Image Neat Video team
noise reduction for video and photos

jpsdr
Posts: 201
Joined: Mon Aug 11, 2008 7:33 am

Post by jpsdr » Mon Feb 13, 2017 7:44 pm

It's not 100% reproducible, and worse...
I had a lot of issues yesterday, when back home earlier VDub hanged just after finishing the 1rst job of a long list, and now VDub has done 4 jobs allready, i didn't even reboot the PC since yesterday, i can't reproduce :cry:
But, i know it will probably happen again, so...
More data :
The plugin is used within VDub, not inside the avs script.
Inside the avs script i use DGIndexNV and my resize plugin.
Within VDub, i use NeatVideo and some of my plugins.
I've done the same process a lot of time with previous version without issue.
I've had a similar issue with DGIndexNV before, it was easier, in that case DGIndexNV was the only plugin used. This issue has been solved since, and never occured again (it was a very rare race condition in the thread synchronisation because of CUDA Init, and i've been only the one having it probably because of my high speed high brand CPU, it was too good... :wink: )
Nevertheless, when it will hang again, i'll provide (like i've done before) the stack of VDub process from ProcessExplorer to DGIndexNV author, to check if it's hanging within it or not. While i'll be at it, is there anything i can provide to you with ProcessExplorer wich may be of use ?
But, for now, NeatVideo is in the first place of suspect, DGIndexNV is only second, because as said, i've done a lot of work until now with previous NeatVideo version without issue.
Both NeatVideo and DGIndexNV use GPU.
OS Windows7 x64, all the process chain is 64bits.
The same script may or may not hang, it's not specific to a script, but my process is "always" the same, so my scripts are all almost identical, it's just the source file which is different.
The same source file may or may not hang.

So, for now, i'm waiting for the next hang.
Last edited by jpsdr on Mon Feb 13, 2017 7:52 pm, edited 1 time in total.

NVTeam
Posts: 2303
Joined: Thu Sep 01, 2005 4:12 pm
Contact:

Post by NVTeam » Mon Feb 13, 2017 7:49 pm

You can also try to disable use of GPU in NV to see if this makes a difference.
Also, try to run it in 64-bit vs 32-bit version of VD. Try to remove some of the effects used together with NV. One of these changes may trigger the problem off, which will give us a hint.

Vlad
Image Image Neat Video team
noise reduction for video and photos

jpsdr
Posts: 201
Joined: Mon Aug 11, 2008 7:33 am

Post by jpsdr » Mon Feb 13, 2017 7:59 pm

I'll see what i can do... (i was editing my post during your reply, you may probably re-read it again).
But as it's not happening so often (bad day bad luck yesterday), it's not easy.
Is there some kind of information that i can provide you with ProcessExplorer or any similar tool when hanging like i've done with the author of DGIndexNV ?

Tim
Posts: 20
Joined: Mon Jun 18, 2012 12:54 am
Contact:

Post by Tim » Tue Feb 14, 2017 1:51 am

Is there some kind of information that i can provide you with ProcessExplorer or any similar tool when hanging like i've done with the author of DGIndexNV ?
Yes, please right click on the hanging process in ProcessExplorer, select Create Dump > Create Minidump.
Once completed, please sent the created file to us for analysis -- see contact details here:
https://www.neatvideo.com/contacts/details

Tim
Image Image Neat Video team
noise reduction for video and photos

jpsdr
Posts: 201
Joined: Mon Aug 11, 2008 7:33 am

Post by jpsdr » Tue Feb 14, 2017 9:05 am

Thanks for your answer, i'll do that when hangs occurs again.
A lot/often of issues sunday, and unable to reproduce yesterday.
It's very irritating... :evil:
Well, at least, during the mean time it's working fine, that's the good part... :wink:

jpsdr
Posts: 201
Joined: Mon Aug 11, 2008 7:33 am

Post by jpsdr » Mon Feb 20, 2017 9:03 am

I've send you an e-mail with the informations.
Nevertheless, my feedbadk with DGIndex seems to pinpoint neither DGIndexNV or NeatVideo.
Just confirm from your side if indeed it's not NeatVideo, in that case, it will close the subject from your side.

NVTeam
Posts: 2303
Joined: Thu Sep 01, 2005 4:12 pm
Contact:

Post by NVTeam » Mon Feb 20, 2017 2:38 pm

Thank you for the minidump. We sent you an e-mail yesterday. Did you receive it?

It doesn't look like Neat Video is causing the problem. It looks like there is some other component causing that. Also, there are quite a lot of threads in that process, which may also be a sign of the problem.

Vlad
Image Image Neat Video team
noise reduction for video and photos

jpsdr
Posts: 201
Joined: Mon Aug 11, 2008 7:33 am

Post by jpsdr » Mon Feb 20, 2017 9:04 pm

NVTeam wrote:Thank you for the minidump. We sent you an e-mail yesterday. Did you receive it?
Yes, i've just read it a little while ago.
NVTeam wrote: It doesn't look like Neat Video is causing the problem. It looks like there is some other component causing that. Also, there are quite a lot of threads in that process, which may also be a sign of the problem.
Ah... Ok, you didn't mention it in your e-mail.
From the stack dump, the author of DGIndexNV told me it was my plugin in the VirtualdubFilterModuleInit2 function which was stuck on a wait event, even if i have no idea why, because i don't call any such function in the Init part of my plugins... :(

Post Reply