Error! Line: 285 Func: Malloc (Cannot get free memory)

resolve technical issues related to use of Neat Video
Post Reply
Posts: 7
Joined: Wed May 20, 2015 2:19 am

Error! Line: 285 Func: Malloc (Cannot get free memory)

Post by picree » Wed May 20, 2015 10:54 am

Using NeatVideo plugin v4. I am using Final Cut Express on Mountain Lion and am trying to process some professionally rendered ProRes 422HQ material at 1080 30P. It was rendered from 24 fps 35mm video. I am interested in removing the film grain but ALSO I need to remove the original dust and scratches.

Unfortunately, FCE must use the Apple Intermediate Codec which "sees" the input material as 1080i. So NV only gets handed a 1920 x 540 field to work with. (I have another question about switching to Final Cut Pro I will post in the general section.) It seems like the unintended deinterlacing would mess up the ability of NV to remove dust and scratches as it's only seeing a synthetic field from an original frame.

So, trying to make FCE hand NV a full frame I changed the Field Dominance from Lower (odd) to None. Now FCE hands NV a full 1920 x 1080 frame to NV. However, when trying to build a Manual Noise Profile of the clip I pretty quickly get a pop-up error dialog (crashing FCE) with the error listed in the post title. (Even before switching to a field dominance of none I am pretty sure I got this same error once or twice...occasionally.)

So...what should I do? There is a Video filter in FCE called Deinterlace. If I applied that to the Sequence before NV instead of changing the Field Dominance would that force FCE hand a full frame to NV? I tried it but without a lengthy render NV still was only seeing a 540 field.

Anyways, are there any other reports of a "Cannot get free memory" error at line 285 in function Malloc? Sounds like a memory leak.

Posts: 2266
Joined: Thu Sep 01, 2005 4:12 pm

Post by NVTeam » Wed May 20, 2015 1:29 pm

It is not a leak but rather a systemic problem of all heavy applications that are built upon old 32-bit architecture. FCE is one of them so it is always limited to about 3.5 GB of memory resources (even if your Mac has much more) and that is relatively low amount for heavy video work. The frame size plays the key role here: the larger the frame size the more memory it takes.

Ideally, it would be best to just switch to the 64-bit version of the application but I understand that Apple doesn't offer such a version of FCE. There are 64-bit FCPX and Motion 5, but those are separate products (although Motion 5 is relatively inexpensive).

In FCP7, there is a way to limit the amount of memory used by the host application itself, which often helps in a situation like that:
Start FCP and go to menu Preferences > System Settings > Memory & Cache > Application

By default, the amount of memory there is set to 100%.
Try reducing the amount to 60-70% and even further to 30-50%.

If more memory remains free then OSX may be more likely to be able to provide it to Neat Video when it is needed for processing.

Remember to restart FCP after changing the above settings.
I am not sure the same adjustment is offered in Preferences of your version of FCE. You may want to check that.

Thank you,
Image Image Neat Video team
noise reduction for video and photos

Posts: 7
Joined: Wed May 20, 2015 2:19 am

Post by picree » Wed May 20, 2015 10:05 pm

OK-Thanks. FCE does have that setting. I will try that to see if it improves the situation!


Edit: Well it allowed me to get a little farther but eventually gave the same error. When I first started editing video last week it worked well so maybe I will reboot to see if that helps.

Post Reply