Question about VDub pluggin

general questions about Neat Video
Post Reply
jpsdr
Posts: 196
Joined: Mon Aug 11, 2008 7:33 am

Question about VDub pluggin

Post by jpsdr » Tue May 31, 2016 2:59 pm

I don't realy know where to ask, so i'm asking here.

Is there a possibility to discuss with a programmer of the Virtual Dub pluggin.
I'm trying to multithread my filter, and encounter some unexplain behaviors. As you've successfuly multi-thread your filter, if possible, i would like to discuss of the strange issue i have, to check if he encountered the same, how basicaly he's doing things.

You can answer me by mail, and things can be done by mail if you don't want to polute this thread.

Thanks.

NVTeam
Posts: 2260
Joined: Thu Sep 01, 2005 4:12 pm
Contact:

Post by NVTeam » Wed Jun 01, 2016 5:56 pm

Please describe your question in details and sent it by e-mail to support [at] neatvideo.com

If that is something familiar, we will offer some comments.

Thank you,
Vlad
Image Image Neat Video team
noise reduction for video and photos

jpsdr
Posts: 196
Joined: Mon Aug 11, 2008 7:33 am

Post by jpsdr » Thu Jun 02, 2016 12:07 am

Thanks for the answer. I've also asked on doom9 (to increase the chances), and someone quickly gave me what was wrong. It was a little tricky, involing copy constructor issues, meaning the fact that i was doing one thing in the Init function instead of the Start function, because a copy constructor was used (meaning the object filter was duplicated). If copy construtor (duplication of the object) wasn't used, it could have worked as it was. Learning everyday... :roll:

NVTeam
Posts: 2260
Joined: Thu Sep 01, 2005 4:12 pm
Contact:

Post by NVTeam » Thu Jun 02, 2016 7:39 am

I am glad you could find the cause and fix the problem.

Vlad
Image Image Neat Video team
noise reduction for video and photos

Post Reply