4.2 OFX Crashing Scratch 8.5 on Launch (Mac Pro Trashcan)

resolve technical issues related to use of Neat Video
Post Reply
pixeljammer
Posts: 4
Joined: Sat Apr 30, 2016 12:47 am

4.2 OFX Crashing Scratch 8.5 on Launch (Mac Pro Trashcan)

Post by pixeljammer » Tue Jul 26, 2016 10:03 pm

OS 10.11.6
3GH 8-Core Intel Xeon E5
64GB RAM
AMD FirePro D700x2

As it says in the title. If I remove the alias file "NeatVideo4.ofx.bundle” from Library/OFX/Plugins, Scratch launches fine.

Any thoughts?

NVTeam
Posts: 2260
Joined: Thu Sep 01, 2005 4:12 pm
Contact:

Post by NVTeam » Thu Jul 28, 2016 2:18 pm

Did the earlier version 4.1.4 work correctly on the same machine?

Please download and try to run the latest build of Neat Image Demo standalone to see if it runs or if also crashes on your machine. Please let me know.

Thank you,
Vlad
Image Image Neat Video team
noise reduction for video and photos

pixeljammer
Posts: 4
Joined: Sat Apr 30, 2016 12:47 am

Post by pixeljammer » Thu Jul 28, 2016 3:00 pm

NVTeam wrote:Did the earlier version 4.1.4 work correctly on the same machine?

Please download and try to run the latest build of Neat Image Demo standalone to see if it runs or if also crashes on your machine. Please let me know.

Thank you,
Vlad
That does not crash Scratch, but that is not the OFX version.

NVTeam
Posts: 2260
Joined: Thu Sep 01, 2005 4:12 pm
Contact:

Post by NVTeam » Thu Jul 28, 2016 3:19 pm

I meant whether Neat Image would crash itself or not, regardless of Scratch.

In the meantime, we could also reproduce crashes of Scratch on the first run of Scratch after installing the new version of Neat Video. Only the first run crashes, while the next runs work without problems.

The crash logs do not show direct involvement of Neat Video into the crash situation, which seem to take place in the host application. We continue investigation and will also contact the developers of Scratch to get additional advice.

Thank you,
Vlad
Image Image Neat Video team
noise reduction for video and photos

pixeljammer
Posts: 4
Joined: Sat Apr 30, 2016 12:47 am

Post by pixeljammer » Thu Jul 28, 2016 3:31 pm

Oh, I see.

I did a search and removed all “neat video”, “neat image” plist, log, mom, bundle, pdf, etc., restarted twice and reinstalled the “NeatVideoOFX.Intel.pkg”. This time, Scratch only crashed on the first launch. Subsequent launches are fine.

crash logs are here: http://files.webbtransfer.com/3W3m252j2B2w

I’m also corresponding with Mazze over at Scratch.

Thanks for your help.

pixeljammer
Posts: 4
Joined: Sat Apr 30, 2016 12:47 am

Post by pixeljammer » Thu Jul 28, 2016 4:15 pm

NVTeam wrote:Did the earlier version 4.1.4 work correctly on the same machine?
New Scratch user. Had not tried it before.

Post Reply