NV not working with interlaced clips in Vegas? - Fixed

questions about practical use of Neat Video, examples of use
Post Reply
Leigh
Posts: 22
Joined: Wed May 30, 2007 11:02 pm

NV not working with interlaced clips in Vegas? - Fixed

Post by Leigh » Thu May 31, 2007 9:16 pm

I've converted some old analogue 8mm (Video8) footage to DV, and I'm now trying to create a PAL DVD of the footage using Neat Video to clean it up (in Vegas 7.0e).

The trouble is the resulting MPEG2 video is all flickery. Something's not right, and it looks like an interlace problem to me. As soon as I disable Neat Video, the resulting MPEG2 video is fine. I've tried setting Neat Video's "Video scan type" setting to both "progressive" and "interlaced", but the resulting footage is still flickery. When the video is being rendered, I can tell something's wrong as the Vegas' preview windows shows an interlaced picture.

I’ve uploaded a sample video to http://www.curvenet.co.uk/nvi_sample.mpg and here's the same clip rendered with NV turned off: http://www.curvenet.co.uk/nv_sample.mpg

Any ideas? This is a bit of a show-stopper for me...
Last edited by Leigh on Sun Jun 03, 2007 4:23 pm, edited 6 times in total.

NVTeam
Posts: 2261
Joined: Thu Sep 01, 2005 4:12 pm
Contact:

Post by NVTeam » Fri Jun 01, 2007 1:23 pm

The problem may be in the project setting. Could you please upload a sample project that would use the original clip, so we would be able to directly reproduce the flickering effect?

Vlad
Image Image Neat Video team
noise reduction for video and photos

Leigh
Posts: 22
Joined: Wed May 30, 2007 11:02 pm

Post by Leigh » Fri Jun 01, 2007 1:32 pm

Hi Vlad.

I've taken this from my email reply to you, in case you haven't received it:

You are correct. My Video8 clips are in the 4:3 format, but I am rendering to 16:9. Vegas happily works like this (and is designed to be this flexible afaik), and the resulting DVDs display perfectly on both 4:3 and 16:9 TVs. I've always used this approach when converting my old 4:3 8mm footage.

NV2.0 does not seem to like this configuration. What can be done to fix this?

I will create a dummy project for you if you think it will help in solving this problem.

NVTeam
Posts: 2261
Joined: Thu Sep 01, 2005 4:12 pm
Contact:

Post by NVTeam » Fri Jun 01, 2007 1:45 pm

Thank you very much. Reproducing the effect directly (using a sample project) will greatly help us diagnose the problem.

Vlad
Image Image Neat Video team
noise reduction for video and photos

Leigh
Posts: 22
Joined: Wed May 30, 2007 11:02 pm

Post by Leigh » Fri Jun 01, 2007 1:52 pm

I will get a sample project to you as soon as I'm home from work.

Thanks for the fast response to my issue.

Leigh
Posts: 22
Joined: Wed May 30, 2007 11:02 pm

Post by Leigh » Fri Jun 01, 2007 4:55 pm

I'm getting two (vertically squashed) frames in NV's preview window when I set the source to interlaced. I assume this is symptomatic of the problem?

I thought I had this sorted but It's still not right, so I'll get that sample project to you tonight. What do you need from me? The project file and a sample DV file?

Leigh
Posts: 22
Joined: Wed May 30, 2007 11:02 pm

Post by Leigh » Fri Jun 01, 2007 6:43 pm

I've sent you a link to my sample project (~25mb). Let me know if you need anything else from me.

NVTeam
Posts: 2261
Joined: Thu Sep 01, 2005 4:12 pm
Contact:

Post by NVTeam » Fri Jun 01, 2007 6:47 pm

"two (vertically squashed) frames in NV's preview window" is normal. Those are not frames, those are two fields (upper and lower) from the interlaced video stream. When you (Vegas, NV, etc) work with interlaced video data, you work with individual fields that are smaller than the full frame. NV simply shows you those two fields in such an explicit way to make sure a noise profile is build correctly.

Again, this is normal when you work in NV with progressive video. The filtration results will look normal.

If you work with progressive video stream in your project then you have to switch NV to the progressive mode (in NV settings panel) and the plug-in will show the progressive frame in preview.

Vlad
Image Image Neat Video team
noise reduction for video and photos

Leigh
Posts: 22
Joined: Wed May 30, 2007 11:02 pm

Post by Leigh » Fri Jun 01, 2007 7:44 pm

That's ok then - Thanks.

Have you managed to download my sample project ok?

NVTeam
Posts: 2261
Joined: Thu Sep 01, 2005 4:12 pm
Contact:

Post by NVTeam » Sat Jun 02, 2007 1:37 am

Unfortunately no, it says "The page cannot be found". I guess there is a typo in the link. Could you check it please?

Thank you,
Vlad
Image Image Neat Video team
noise reduction for video and photos

Leigh
Posts: 22
Joined: Wed May 30, 2007 11:02 pm

Post by Leigh » Sat Jun 02, 2007 10:24 am

Sorry Vlad - 7z files don't appear to download from my webspace. Weird!

I've re-uploaded and sent you another email.

Leigh

Leigh
Posts: 22
Joined: Wed May 30, 2007 11:02 pm

Post by Leigh » Sun Jun 03, 2007 10:05 am

My email is playing up, so I thought I'd post here to be sure you get my reply.

Basically, your suggestion worked. NV works properly if I set each clip in turn to progressive scan. However, my clips are all DV interlaced, so it would be a pain to have to change each one in turn, just for NV). Everything else in Vegas happily works with DV interlaced.

Shouldn't NV work with interlaced clips? I was under the impression it did when I purchased it, and there is an interlaced setting in NV. It looks like Vegas is doing something to confuse NV.

I never work with progressive video, as all of my footage is DV interlaced and hi-def interlaced (1080i). To have to change all of my clips to progressive is a real problem for me, as I have many clips in my project(s).

Thanks Vlad.

Leigh

Leigh
Posts: 22
Joined: Wed May 30, 2007 11:02 pm

Post by Leigh » Sun Jun 03, 2007 4:20 pm

Update for anyone following this thread:

The NV team has identifed the cause of the problem I've been experiencing and, can you believe it, they've already fixed it! The test build I've received from the works perfectly with my media in Vegas.

I just want to publicy say that I'm blown away by the level of support (and the speed all responses) that I've received since puchasing NV just days ago.

I'm one *very* happy NV user.

Thats to all at NV (especially Vlad).

BTW: I've updated the original thread title to reflect that this is no longer a problem for NV. Wouldn't want to put off any prospective customers.

Joran
Posts: 47
Joined: Sun Jan 08, 2006 2:48 am
Location: Oslo, Norway

Post by Joran » Sun Jun 03, 2007 5:41 pm

One question: When can we download this new version of NeatVideo for Sony Vegas?


Jøran Toresen

NVTeam
Posts: 2261
Joined: Thu Sep 01, 2005 4:12 pm
Contact:

Post by NVTeam » Sun Jun 03, 2007 5:55 pm

We will release a regular update that will include this correction. I expect it later this month.

Vlad
Image Image Neat Video team
noise reduction for video and photos

Post Reply