Frame Size

resolve technical issues related to use of Neat Video
RAYWEB
Posts: 11
Joined: Wed Feb 15, 2006 6:00 am
Location: NY

Frame Size

Post by RAYWEB » Thu Feb 16, 2006 4:56 am

In the bottom of the screen the frame size reads 720x240
even though I know its 720x480. Any suggestions?

Next I am trying to decrease low light video noise which is
mainly in the blue channel from what I have read. What is the best way
to do this? Profile quality =33%.

Is the unsharp mask a better tool then your sharpening filter?

Thanks

NVTeam
Posts: 2261
Joined: Thu Sep 01, 2005 4:12 pm
Contact:

Post by NVTeam » Thu Feb 16, 2006 11:10 am

The 720x240 size is most likely caused by working with interlaced frames (support for such frames in NV is currently limited though we are going to improve this aspect in the future updates). Please try to set following value: "No Fields (Progressive Scan)" in the following project setting: Project Settings | General | Fields. This should make Premiere provide 720x480 frames to the plug-in.

Regarding low light video noise and low profile quality. The most important is to build an accurate noise profile. Usually, an accurate profile's quality is much closer to 100% than 33%. I recommend to select another area in the frame for analysis (select the most noisy, middle-bright, largest available, flat and featureless area) and use Auto Profile to build a profile based on that area. If there is no suitable area in the current frame, try to find another frame with more flat areas.

Regarding unsharp mask and NV smart sharpening, they are different in several ways. First of all, NV sharpening works in conjunction with noise profile which helps to skip noise elements and to sharpen only details. Unsharp mask cannot make this distinction, it sharpens everything. Also, NV sharpening is adjustable in three frequency ranges, while unsharp mask has only one. All this doesn't mean one is better than the other. On the contrary, both have their strong sides and are not mutually exclusive.

Hope this helps.
Vlad
Image Image Neat Video team
noise reduction for video and photos

RAYWEB
Posts: 11
Joined: Wed Feb 15, 2006 6:00 am
Location: NY

progressive frames

Post by RAYWEB » Fri Feb 17, 2006 2:35 am

This option to set progressive frames is not available to change. Box
is grayed out.
The field options box has always deinterlace as a choice yet that does not work on your program.

What is abit sad is that if the filter had the whole 720x480 to
work with the area needed for analysis would be half as big.

NVTeam
Posts: 2261
Joined: Thu Sep 01, 2005 4:12 pm
Contact:

Post by NVTeam » Fri Feb 17, 2006 2:42 am

I think you still can change that option if you create a new project. Just try to create a new project to see whether that option is enabled.

Vlad
Image Image Neat Video team
noise reduction for video and photos

RAYWEB
Posts: 11
Joined: Wed Feb 15, 2006 6:00 am
Location: NY

tried it

Post by RAYWEB » Fri Feb 17, 2006 3:35 am

Did everything but no luck

RAYWEB
Posts: 11
Joined: Wed Feb 15, 2006 6:00 am
Location: NY

Interesting

Post by RAYWEB » Fri Feb 17, 2006 4:11 am

Well I went on to a new clip, apllied your filter and the box read 720x480
then I rendered the clip played it and decide to go back to adjust
a few parameters and it opens up 720x280. and I cant seem to be able to
rerender it since the bar above the clip stays green, so thats it.

NVTeam
Posts: 2261
Joined: Thu Sep 01, 2005 4:12 pm
Contact:

Post by NVTeam » Fri Feb 17, 2006 11:12 am

Could you describe all the settings you use in the project please?

Which version of Premiere is it? Do you use the high quality setting in Premiere's preview window ("Program: Sequence ##")?

To get rid of the green bar, try to use Sequence->Delete Render Files in Premiere.
Image Image Neat Video team
noise reduction for video and photos

RAYWEB
Posts: 11
Joined: Wed Feb 15, 2006 6:00 am
Location: NY

Settings ect.

Post by RAYWEB » Thu Feb 23, 2006 4:13 am

Settings:

general: MatroxRT.X, 720x480, D1/DV, 30 fps drop-frame
capture: Matrox AVI capture
Video rendering: Matrox DV/DVCAM compressor
Display mode : Highest quality

Premiere 1.51, 2 SATA drives (one is a/v) P3.2 hyper threading
with 1 gig ram.

Another problem is rendering times: after 27 hours Canopus Procoder v2.0 didnt finish rendering a 70 min timelime to DVD compliant MPEG2.
Normally this takes only about 8 hours. The video uses your filter
extensively.

NVTeam
Posts: 2261
Joined: Thu Sep 01, 2005 4:12 pm
Contact:

Post by NVTeam » Thu Feb 23, 2006 10:09 am

There should also be the following setting: Project settings -> General -> Fields. What settings is there?

If you cannot change it, try to use the following menu command in Premiere: Clip->Video options->Field Options. In the Field Options window, select Always Deinterlace.

Regarding processing time, yes, noise reduction is a computationally intensive process which takes time. You may want to disable the High quality setting in Noise Filter Settings (you have to enable Tools -> Advanced mode to see that setting), this will make filtration somewhat faster.

Also, make sure you have enabled Tools -> Options -> General -> Enable multiprocessor support to utilize hyper threading capabilities of your P4.

Vlad
Image Image Neat Video team
noise reduction for video and photos

RAYWEB
Posts: 11
Joined: Wed Feb 15, 2006 6:00 am
Location: NY

settings

Post by RAYWEB » Sat Feb 25, 2006 12:02 am

Fields show : lower field first and cant be changed.
Multi processor support was already enabled.
Always deinterlace is selected.

Thanks

NVTeam
Posts: 2261
Joined: Thu Sep 01, 2005 4:12 pm
Contact:

Post by NVTeam » Sat Feb 25, 2006 12:24 am

When I start Premiere Pro 1.5 and create a new project, I can select: Fields: No Fields (Progressive Scan), this parameter is not disabled.

Please try to create a new project, I expect that parameter will be enabled in your copy of Premiere as well.

Thank you,
Vlad
Image Image Neat Video team
noise reduction for video and photos

RAYWEB
Posts: 11
Joined: Wed Feb 15, 2006 6:00 am
Location: NY

Settings

Post by RAYWEB » Sun Feb 26, 2006 6:34 pm

Well I just found out that my Matrox card does not support progressive frame editing. When I start a new project in Premiere as DV-NTSC
go to custom srettings, then I can change the fields to Progressive and yes
your program shows full 720x480 size. So I just cant use the Matrox DV
editing mode.

So what I am trying is to get the settings off the regular premiere
mode save them, then open a parallel copy of the same project in the
Matrox mode and apply them ( in neat) to the clip there which should work.

Thanks for your help.

bjrohner
Posts: 10
Joined: Wed Apr 26, 2006 3:01 pm

Can't find a solution to Frame Size

Post by bjrohner » Wed Apr 26, 2006 3:16 pm

I've read all your posts and tried everything you suggested to correct the frame size problem. I'm using elements 2.0. Tried always deinterlace on the clip - removed any field blend - tried starting from scratch - tried other clips.
The clips are captured in elements from a mini-DV.

Do you have any more ideas? Is this a problem you may be able to correct later?

Although it makes it difficult to find a good target, Neat Video seems to do a decent job on the preview at any rate but I don't know if it will give me the quality I'm looking for on the actual output. What do you think?

Also, looking forward to your Vegas up-date since I prefer to us it.

Thanks
Bob

NVTeam
Posts: 2261
Joined: Thu Sep 01, 2005 4:12 pm
Contact:

Post by NVTeam » Wed Apr 26, 2006 4:04 pm

Bob,

In the latest version (v1.1) of Neat Video for Premiere, the plug-in does not deinterlace video data it works with because Premiere conducts rendering in interlaced format, so NV has to render interlaced frames as well and therefore it should build profiles using interlaced frames too. That is why NV shows a smaller frame when you build profiles and adjust filters. So, it is normal when you work with interlaced video data in Premiere and NV.

Another solution would be to deinterlace the video sequence from the very beginning and then work with progressive frames only. NV would then build profiles and apply filtration to progressive frames only, in line with the rest of the Premiere workflow.

Hope this helps.
Vlad
Image Image Neat Video team
noise reduction for video and photos

bjrohner
Posts: 10
Joined: Wed Apr 26, 2006 3:01 pm

Thank you All

Post by bjrohner » Wed Apr 26, 2006 5:52 pm

I want to thank you all. Neat is a class act. I've been using Neat image for several years and can't believe the quality it adds to my old photos. In fact, scanned in images from an old year book with huge artifacts were made to look as if a pro had just taken them. Now it turns out your support is every bit as good as your product.

I tried deinterlacing the movies with a file converter but it made no difference . Maybe elements just doesn't have the flexibility that it's big brother has. I can work around it at any rate until you find a correction or your Vegas version comes out.

I've been working on old movies that were converted and frankly I believe they did a lousy job for the cost. I am confident that your product will correct their screw-up.

Bob

Post Reply