Premiere CS5.5-random switching between 8 bit and 32 bit RGB

resolve technical issues related to use of Neat Video
Post Reply
Felix
Posts: 12
Joined: Fri Jul 13, 2012 12:06 am

Premiere CS5.5-random switching between 8 bit and 32 bit RGB

Post by Felix » Fri Jul 13, 2012 1:01 am

Hi,

I just purchased Neat Video and I´m blown away!
But there seems to be a glitch in the programm, I don´t know if it´s serious

I´m using 10 bit (with 8 bit source) ProRes Footage and 8 bit AVCHD. When I start Neat video, sometimes it shows me Fame: 1920x1080 8-bit RGB and sometimes Frame: 1920x1080 32-bit RGB on the lower right of the frame.

Of course I want to do the processing in 32bit.
If it shows me 8 bit I can scrubb through the timeline a little, reopen Neat Video and it´s 32 bit, scrubbing a little more, 8 bit again. It just changes randomly as I go trough my timeline.

Is that only an indication error or should I make sure to get the 32 bit "version"

Pictures:

8 bit: Image

and then, 1 second earlier in the clip:
Image


And a second question: Why does Neat Video denoise even when it´s set to 0 % ? My Prores footage just needed a very small amount of denoising. I went down from 15% luma, 10 %, 5 %, 0%....and it´s still a little too much denoising at 0%.

NVTeam
Posts: 2261
Joined: Thu Sep 01, 2005 4:12 pm
Contact:

Re: Premiere CS5.5-random switching between 8 bit and 32 bit

Post by NVTeam » Fri Jul 13, 2012 10:03 am

Hello Felix,

Thank you for your comments, I am glad you like Neat Video.

I will answer your questions:
Felix wrote:If it shows me 8 bit I can scrubb through the timeline a little, reopen Neat Video and it´s 32 bit, scrubbing a little more, 8 bit again. It just changes randomly as I go trough my timeline.

Is that only an indication error or should I make sure to get the 32 bit "version"
It is not an indication error, it is not bug in Neat Video, it is the right version that can process 32-bit data just fine. The cause of the above effect is Premiere itself. Sometimes it works with 8-bit data to speed up its own preview (typically, when playing video in preview, as opposed to the stopped state when it shows one frame), sometimes it switches to 32-bit bitdepth - usually when you just stay in one frame or when you select a new frame in the timeline and then let Premiere's activities to settle down a bit (typically 1-2 seconds) before opening Neat Video's window. The latter gives Premiere time to switch preview to the 32-bit quality and then it sends 32-bit data to Neat Video. If you do not wait for it to settle down, Premiere may still send a lower bitdepth data to the plug-in. So basically, it is all about Premiere itself, the way it works with preview, the way it decides when to use 8-bit or 32-bit data. Neat Video is just a messenger there, showing the result of that decision made by Premiere.
In principle, it should be possible to adjust that behaviour of Premiere to force it to work in 32-bit precision. There are options like Maximim Bit Depth, Maximum Render Quality in Premiere's Sequence Settings and I think they are supposed to do that. You may want to experiment with them a bit.
Felix wrote:And a second question: Why does Neat Video denoise even when it´s set to 0 % ? My Prores footage just needed a very small amount of denoising. I went down from 15% luma, 10 %, 5 %, 0%....and it´s still a little too much denoising at 0%.
Besides the intra-frame noise filter that you are adjusting (that Noise Reduction Amount in Luminance channel controls the intra-frame filter) there is also the temporal filter, which also applies noise reduction based on analysis of several consecutive frames. Its settings are available in Premiere's panel. For example, if you set the temporal filter radius to 0, this will effectively disable the temporal filter, and then there should be no filtration at all.

Hope this helps,
Vlad
Image Image Neat Video team
noise reduction for video and photos

Felix
Posts: 12
Joined: Fri Jul 13, 2012 12:06 am

Post by Felix » Fri Jul 13, 2012 5:45 pm

Alright, thanks a lot!
I make sure to get 32 bit.

Post Reply